-
CVE-2023-45282: In openmct 2.2.5 before 545a177, prototype pollution can occur via an import action.(9th Oct 2023)
Preface: Java is highly functional in several data science processes like data analysis, including data import, cleaning data, deep learning, statistical analysis, Natural Language Processing (NLP), and data visualization. Background: Open MCT Web is a platform single page applications which runs entirely in the browser. Most applications will want to additionally interact with server side…
-
Security Focus: CVE-2023-21266 (6th Oct 2023)
Preface: Smartphone is a digital world microcosm. We know that our digital world includes web services, repositories, virtual machines, high-speed networks, multi-core CPUs, and GPUs. But the average smartphone already includes the infrastructure components just mentioned. Therefore, the security level of smartphones is no less than that of enterprise servers, because this micro world is…
-
CVE-2023-33106, CVE-2023-33107, CVE-2022-22071 and CVE-2023-33063: Where do your weaknesses belong? (5th Oct 2023)
Preface: There are indications from Google Threat Analysis Group and Google Project Zero that CVE-2023-33106, CVE-2023-33107, CVE-2022-22071 and CVE-2023-33063 may be under limited, targeted exploitation. Patches for the issues affecting Adreno GPU and Compute DSP drivers have been made available, and OEMs have been notified with a strong recommendation to deploy security updates as soon…
-
CVE-2023-34970: ARM Security Advisory published a number of design flaws. Can we guess what this CVE is about? (4th Oct 2023)
Preface: Rather than processing tasks serially (sequentially) like a CPU, a GPU breaks up tasks and runs them in parallel. GPUs have many more cores than CPUs. Background: The Roofline model is an intuitive visual performance model used to provide performance estimates of a given compute kernel or application running on multi-core, many-core, or accelerator…
-
CVE-2023-4211: Mali GPU Kernel Driver allows improper GPU memory processing operations (2nd Oct 2023)
Preface: Double Free and Use After Free are Common IoT Security Weaknesses. For example: Calling free() twice on the same value causes a memory leak. So, it is easy to encounter this design weakness. Background: Arm Mali-G720, is designed on the Arm 5th Gen architecture to deliver improved performance while reducing memory bandwidth usage, power…
-
Google is aware that an exploit for CVE-2023-5217 exists in the wild but it solved in fast manner (29-09-2023)
Preface: A heap overflow condition is a buffer overflow, where the buffer that can be overwritten is allocated in the heap portion of memory, generally meaning that the buffer was allocated using a routine such as malloc(). Background: A video codec is software or hardware that compresses and decompresses digital video. The libvpx is a…
-
CVE-2023-43642: Missing upper bound check on chunk length in snappy-java can lead to Denial of Service! (28-09-2023)
Preface: The classes in the java. util. zip package support two widespread compression formats: GZIP and ZIP. Both of these are based on the ZLIB compression algorithm, which is discussed in RFC 1950, RFC 1951, and RFC 1952. Background: Compression Ratio: Gzip generally achieves a higher compression ratio than Snappy. If storage space is a…
-
CVE-2023-5158: Trigger Denial of service via zero-length descriptor from guest to host (27-09-2023)
Preface: In the virtio protocol, the host side provides emulation of the device, and the guest side is responsible for driving the device. The relationship between host and guest is the relationship between device and driver. We usually use the method of reading and writing temporary registers to control and drive physical devices, but for…
-
CVE-2023-42753: Missing macro could lead to a miscalculation causes memory buffer out-of-bound in Netfilter Kernel sub system . (26-09-2023)
Preface: Netfilter is an infrastructure; it is the basic API that the Linux 2.4 kernel offers for applications that want to view and manipulate network packets. Background: It can not only block unwanted traffic but also block malicious software from infecting the system. In the Linux ecosystem, iptables is a popular firewall that interfaces with…
-
XSA-273 – Xen Security Advisories (CVE-2023-34319) – Guests can trigger NIC interface reset/abort/crash via netback (24th Sep 2023)
Preface: Xen is an open-source hypervisor that allows the simultaneous development, execution, and management of multiple virtual machines on one physical computer. Xen offers two types of virtualization: paravirtualization and full virtualization. Background: XenServer is a Citrix product the company acquired from XenSource in 2007. Citrix’s XenServer provides 7 Network interface cards and 16 virtual…