-
CVE-2019-12098 – Heimdal design limitation causes man-in-the-middle attack Vulnerability – 20th May 2019
Preface: Before Kerberos, Microsoft used an authentication technology called NTLM. Technical background: The biggest difference between the two systems is the third-party verification and stronger encryption capability in Kerberos. Kerberos version 4 was targeted at Project Athena in 80s. Neuman and Kohl published version 5 in 1993 to improve the limitations and enhance the security.…
-
New order in the Asia-Pacific region – Cyber security Law 2019
China Cracks Down on Foreign Firms Over Cyber Security, FT Says – two foreign companies that deal with consumer data in China had been under official investigation for several months.For details about the News, please refer below link:https://www.ft.com/content/b84cc734-76ca-11e9-bbad-7c18c0ea0201 Supplement:https://www.bloomberg.com/news/articles/2019-05-16/china-cracks-down-on-foreign-firms-over-cyber-security-ft-says Synopsis: Information technology personnel are familiar with MPLS. But do they understand China’s MLPS (multi-level protection…
-
Security Focus – VMware (May 2019)
Preface: Intel flaw let VMware become victim (CVE-2018-12126, CVE-2018-12127, CVE-2018-12130, and CVE-2019-11091) ! VMware Workstation update addresses a DLL-hijacking issue (CVE-2019-5526) looks not a news? VMware Vulnerability details: VMware Workstation update addresses a DLL-hijacking issue (CVE-2019-5526) – https://www.vmware.com/security/advisories/VMSA-2019-0007.html VMware product updates enable Hypervisor-Specific Mitigations, Hypervisor-Assisted Guest Mitigations, and Operating System-Specific Mitigations for Microarchitectural Data Sampling…
-
Do not contempt “CVE-2019-0708” (Remote Desktop Services Remote Code Execution) Vulnerability – 14th May 2019
Preface: Heard that Microsoft is trying to head off another WannaCry-style malware outbreak before it starts. Technical background: Remote Desktop Protocol is based on, and is an extension of, the T-120 family of protocol standards. Vulnerability details: A vulnerability in the Remote Desktop Services component of Microsoft Windows could allow an unauthenticated, remote attacker to…
-
Cisco follow up vulnerability item: Cisco Secure Boot Hardware Tampering Vulnerability (May 2019)
Preface: If you could talk to God. And ask in the world who can be trust? He will reply…… About technology risk for the FPGA:How to trusting an external party with maintaining keys that protect the FPGA configuration? A common practice till now is that it is a distinction between trust in operational processes and…
-
If I am true – WhatsApp vulnerability ( CVE-2019-3568) – May 2019
Preface: I do not care about this vulnerability since social media communication not secure by far. This is not the news. Headline news: Facebook Releases Security Advisory for WhatsApp. A remote attacker could exploit this vulnerability to take control of an affected device. For more details, please refer following url – https://www.facebook.com/security/advisories/cve-2019-3568 About vulnerability background…
-
CVE-2019-11365 – atftp atftpd Stack-Based Buffer Overflow Vulnerability (13th May 2019)
Preface: TFTP was primarily designed to read or write files by using a remote server. It fully compliant with all related RFCs. This include RFC1350, RFC2090, RFC2347, RFC2348 and RFC2349. Background: It is used where user authentication and directory visibility are not required. So, the design goal is cater for non confidential file sharing because…
-
CVE-2019-3561 – Insufficient boundary checks for the strrpos and strripos functions allow access to out-of-bounds memory ( 30th Apr 2019)
Preface: The software reads data past the end, or before the beginning, of the intended buffer. It may allow access to sensitive memory. This is so called “out of bounds read”. Technical background: HHVM is an open-source virtual machine designed for executing programs written in Hack and PHP. HHVM uses a just-in-time (JIT) compilation approach…
-
cJSON vulnerabilities found, API design which use in-memory data structure store, used as a database, cache and message broker solution must staying alert. (May 2019)
Preface: Lua is a powerful, fast, lightweight, embeddable scripting language. So it can work with Geospatial data perfectly. Technical background: Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache and message broker. In order to achieve its outstanding performance, Redis contains different functions.The Redis Lua interpreter loads seven…
-
As of May 9, 2019, even “Virustotal” did not have his record! where is he from?
Preface: The Department of Homeland Security (DHS) and the Federal Bureau of Investigation (FBI) have identified a malware variant— so called ELECTRICFISH. Technical details: The malware implements a custom protocol like “Tor browser”. The aim to allows traffic by-pass defense mechanism in between source and a destination Internet Protocol (IP) address. The malware continuously attempts…